まず、
gem install pg 
でこける。

gem install pg -- --with-pg-config=/usr/local/pgsql/bin/pg_config

でインストールはできたけど、rake db:create しようとしたら、今度は表題のエラーが出る。

libpq.so.5
が見つからないと言っているようです。

でも
/usr/local/pgsql/lib
にはちゃんとある。
ってことは単にパスが通ってないだけか、、、。でも、だいぶ前に通してたはずなんだけどなー、、、、あ、あれは別のマシンか、、、。

.bash_profileとか .zshrcとかに

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/pgsql/lib

でちゃんとできました。

どうもパス通し忘れでハマることが多い、、、。